Error with the get_response method

I run the get_response(“…”) method and it returns this error:

Traceback (most recent call last):
~~~~home/alon/Desktop/mycroft-core/mycroft/skills/", line 342, in handle_converse_request
    self._emit_converse_response(message, skill_loader)
~~~~home/alon/Desktop/mycroft-core/mycroft/skills/", line 364, in _emit_converse_response
    result = skill_loader.instance.converse(utterances, lang)
TypeError: converse() takes 2 positional arguments but 3 were given
~~~~8:07.510 | ERROR    |  2596 | mycroft.client.speech.listener:transcribe:226 | list index out of range
~~~~ 2596 | mycroft.client.speech.listener:transcribe:227 | Speech Recognition could not understand audio

Does someone know how to solve it?
Thank You, 

Does anyone know?
Thank You

Hi Alon,

I can’t replicate the issue, but have had a look at your code and noticed that a few of your calls to get_response are missing the self, they should be:


This is because the method is provided by the MycroftSkill class which self has inherited from.

Does that solve the problem by any chance?

It solved the problem. Thank You

1 Like